DELPHI. Написать программу, которая вводит массив из N целых чисел и выводит на экран ?
DELPHI. Написать программу, которая вводит массив из N целых чисел и выводит на экран ??тот же массив в прямом и обратном порядке. Протестировать программу на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.
Ответ(ы) на вопрос:
Const
handsfree = false;
var
a: array[1..100] of integer;
i, n: integer;
begin
{ввод массива}
if handsfree then
n := random(20) + 5
else begin
write('n = ');
readln(n);
end;
writeln('Данные массива:');
for i := 1 to n do
begin
if handsfree then begin
a[i] := random(100) - 50;
write(a[i], ' ');
end
else readln(a[i]);
end;
writeln();
{изменение элементов}
writeln('Вывод прямой:');
for i := 1 to n do
write(a[i], ' ');
writeln();
{изменение элементов}
writeln('Вывод обратный:');
for i := n downto 1 do
write(a[i], ' ');
end.
Не нашли ответ?
Похожие вопросы