Добрый день. Нужна помощь в паскале. Необходимо составить программу подсчёта количества нулевых элементов в массиве А(100). Буду премного благодарен. Спасибо.
Добрый день. Нужна помощь в паскале.
Необходимо составить программу подсчёта количества нулевых элементов в массиве А(100).
Буду премного благодарен. Спасибо.
Ответ(ы) на вопрос:
const
n=100; { размер массива }
var
a:array[1..n] of integer;
i,k:integer;
begin
{ заполняем массив случайными значениями }
Randomize;
k:=0;
Writeln('Элементы массива');
for i:=1 to n do
begin
a[i]:=Random(41)-20;
Write(a[i],' ');
if a[i]=0 then Inc(k)
end;
Writeln;
Writeln('Нулевых элементов: ',k)
end.
Не нашли ответ?
Похожие вопросы