Это в Паскале. Первая задача: Дана последовательность чисел,оканчивающихся отрицательным числом. Найти среднее арифметическое введенных положительных чисел. И вторая: Дана последовательность чисел,количество которых заранее не ...

Это в Паскале. Первая задача: Дана последовательность чисел,оканчивающихся отрицательным числом. Найти среднее арифметическое введенных положительных чисел. И вторая: Дана последовательность чисел,количество которых заранее не известно. Сколько чисел было введено до первого нуля? Буду очень благодарен,если ответите.
Гость
Ответ(ы) на вопрос:
Гость
{1} var     i, n, s: integer; begin     i := 0;     writeln('Введите последовательность чисел,оканчивающихся отрицательным числом');     repeat         readln(n);         if n > 0 then begin             s := s + n;             i := i + 1;         end;     until n < 0;     writeln(s / i); end. {2} var     i, n: integer; begin     i := 0;     writeln('Введите последовательность чисел,оканчивающихся 0');     repeat         readln(n);         if n <> 0 then             i := i + 1;     until n = 0;     writeln(i); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы