Идет i-ая секунда суток. Напишите программу, которая по введенной i-ой секунде суток определит, сколько целых часов h, целых минут min и секунд с прошло с начала суток. Например: 13257 секунд = 3 часа 40 минут и 57 секунд. Выве...

Идет i-ая секунда суток. Напишите программу, которая по введенной i-ой секунде суток определит, сколько целых часов h, целых минут min и секунд с прошло с начала суток. Например: 13257 секунд = 3 часа 40 минут и 57 секунд. Выведите на экран фразу: «С начала суток прошло: …. часов, ….. минут и …. секунд». Вместо многоточий вывести значения переменных.
Гость
Ответ(ы) на вопрос:
Гость
var   i, h, m, s: integer; begin   Write('Введите количество секунд от начала суток: ');   Readln(i);   h := i div 3600;   m := i mod 3600;   s := m mod 60;   m := m div 60;   Writeln('С начала суток прошло ', h, ' часов, ', m, ' минут ', s, ' cекунд') end. Тестовое решение: Введите количество секунд от начала суток: 13257 С начала суток прошло 3 часов, 40 минут 57 cекунд
Не нашли ответ?
Ответить на вопрос
Похожие вопросы