Используя сначала цикл с условием, а затем - цикл с переменной, напишите программу, которая выводит на экран четные степени числа 2 от [latex] 2^{10} [/latex] до [latex] 2^{2} [/latex] в порядке убывания

Используя сначала цикл с условием, а затем - цикл с переменной, напишите программу, которая выводит на экран четные степени числа 2 от [latex] 2^{10} [/latex] до [latex] 2^{2} [/latex] в порядке убывания
Гость
Ответ(ы) на вопрос:
Гость
Четные степени числа 2 - это все равно что целые степени числа 4 от [latex]4^5=1024[/latex] до [latex]4^1=4[/latex]. Программы на Pascal: program first; var i:integer; begin   i:=1024;   while i>1 do begin     writeln(i);     i:=i div 4;   end; end. program second; var i,pow:integer; begin   i:=1024;   for pow:=5 downto 1 do begin     writeln(i);     i:=i div 4;   end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы