Используя язык программирования pascal, написать программу, которая вычисляет следующую сумму S= (2*4)/(1+2)-(6*8)/(2+3)+(10*12)/(3+4)-...-(54*56)/(14+15) и выводит ее результат. Писать нужно через цикл, желательно, с пояснением.

Используя язык программирования pascal, написать программу, которая вычисляет следующую сумму S= (2*4)/(1+2)-(6*8)/(2+3)+(10*12)/(3+4)-...-(54*56)/(14+15) и выводит ее результат. Писать нужно через цикл, желательно, с пояснением.
Гость
Ответ(ы) на вопрос:
Гость
var i,z:integer; a,s:real; begin s:=0; z:=-1; for i:=1 to 56 div 4 do  begin  z:=-z;  a:=z*(i*4-2)*(i*4)/(i+i+1);  // для наглядности:  writeln(z,' ',i*4-2,' ',i*4,' ',i,' ',i+1);  s:=s+a;  end; writeln('s = ',s); end. Результат: 1 2 4 1 2 -1 6 8 2 3 1 10 12 3 4 -1 14 16 4 5 1 18 20 5 6 -1 22 24 6 7 1 26 28 7 8 -1 30 32 8 9 1 34 36 9 10 -1 38 40 10 11 1 42 44 11 12 -1 46 48 12 13 1 50 52 13 14 -1 54 56 14 15 s = -54.4163713045239
Не нашли ответ?
Ответить на вопрос
Похожие вопросы