Известны три натуральных числа C– часы, M – минуты, S – секунды. Написать программу используя условный оператор, которая определяет время через 15 секунд.Пожалуйста нужно сделать через Pascal !

Известны три натуральных числа C– часы, M – минуты, S – секунды. Написать программу используя условный оператор, которая определяет время через 15 секунд. Пожалуйста нужно сделать через Pascal !
Гость
Ответ(ы) на вопрос:
Гость
var c,m,s:integer; begin readln(c,m,s); if s>=45 then begin m:=m+1; s:=s+15-60; end else s:=s+15; if m>=59 then begin  c:=c+1; m:=0; end; if c>=24 then c:=0; writeln(c,' ',m,' ',s); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы