Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элемент...
Хотя бы 3-4 задачи!
1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5).
2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
3) Дан одномерный целочисленный массив А, состоящий из N элементов. Найдите произведение всех нечетных элементов массива.
4) Дан двумерный массив размерностью NXM, заполненный случайными числами. Заменить все четные элементы массива на 2, а нечетные на 1. На экран вывести исходный и новый массив.
5) Дан двумерный массив размерностью NXM, заполненный случайными числами. Напишите программу, в результате выполнения которой все элементы массива увеличиваются в 2 раза. На экран вывести исходный и новый массив.
Ответ(ы) на вопрос:
Гость
Сделал все!) поставь наилучшее!
1)var a:array [0..5] of Integer; i,j:Integer;
begin
Randomize;
j:=0;
for i:=0 to 5 do
a[i]:=Random(100);
for i:=0 to 5 do
if a[i] mod 3 =0 then
Inc(j);
Writeln(j);
readln;
2)var a:array [0..5] of Integer; i,j:Integer;
begin
Randomize;
j:=0;
for i:=0 to 5 do
a[i]:=Random(100);
for i:=0 to 5 do
if a[i] mod 2 =0 then
j:=j+a[i];
Writeln(j);
readln;
3)a:array [0..5] of Integer; i,s:Integer;
begin
Randomize;
s:=1;
for i:=0 to 5 do
a[i]:=Random(9)+1;
for i:=0 to 5 do
if i mod 2 <>0 then
s:=s*a[i];
Writeln(s);
readln;
end.
4)const n=5;m=5;
var a:array [0..n,0..m] of Integer; i,j:Integer;
begin
Randomize;
for i:=0 to n do
for j:=0 to m do
a[i,j]:=Random(100);
for i:=0 to n do
begin
Writeln;
for j:=0 to m do
write(a[i,j]:3);
end;
for i:=0 to n do
for j:=0 to m do
begin
if a[i,j] mod 2 =0 then
a[i,j]:=2
else if a[i,j] mod 2 <>0 then
a[i,j]:=1;
end;
Writeln;
for i:=0 to n do
begin
Writeln;
for j:=0 to m do
write(a[i,j]:3);
end;
Readln;
end.
5)const n=5;m=5;
var a:array [0..n,0..m] of Integer; i,j:Integer;
begin
Randomize;
for i:=0 to n do
for j:=0 to m do
a[i,j]:=Random(10);
for i:=0 to n do
begin
Writeln;
for j:=0 to m do
write(a[i,j]:3);
end;
for i:=0 to n do
for j:=0 to m do
a[i,j]:=a[i,j]*2;
Writeln;
for i:=0 to n do
begin
Writeln;
for j:=0 to m do
write(a[i,j]:3);
end;
Readln;
end.
Не нашли ответ?
Похожие вопросы