Кто понимает Паскаль, обращаюсь к вам! Очень нужна ваша помощь! Составьте программу, которая выводит все символы до первого многоточия и программу, которая заменяет каждое многоточие точкой и каждый пробел точкой.
Кто понимает Паскаль, обращаюсь к вам! Очень нужна ваша помощь! Составьте программу, которая выводит все символы до первого многоточия и программу, которая заменяет каждое многоточие точкой и каждый пробел точкой.
Ответ(ы) на вопрос:
// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
var p:=Pos('...',s);
if p>0 then Writeln(Copy(s,1,p-1))
end.
Пример
> Это такая... тестовая... строка
Это такая
// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('>');
Writeln(s.Replace('...','.').Replace(' ','.'))
end.
Пример
> Это такая... тестовая строка, надуманная...
Это.такая..тестовая.строка,.надуманная.
Не нашли ответ?
Похожие вопросы