Кто разбирается? Короче, такая хрень, помогите пожалуйста! Составьте программу, которая формирует массив из шестнадцати случайных целых чисел от -20 до 20 и: а) находит элементы с нулевыми знаниями; б) находит индексы нечетны...
Кто разбирается? Короче, такая хрень, помогите пожалуйста! Составьте программу, которая формирует массив из шестнадцати случайных целых чисел от -20 до 20 и: а) находит элементы с нулевыми знаниями; б) находит индексы нечетных элементов; в) подсчитывает количество положительных элементов. -Ну? Кто тут умный?
Ответ(ы) на вопрос:
Гость
На каком языке программирования?
Паскаль АБС
var
i,count:integer;
a:array [1..16] of integer;
begin
for i:=1 to 16 do begin
a[i]:= Random (-20,20);
end;
for i:=1 to 16 do begin
if (a[i] = 0) then
writeln ('Нулевой элемент ',a [i]);
if (a [i] mod 2 = 1) then
writeln ('Индекс нечетного элемента ',i);
if (a [i] >0) then
inc (count);
end;
writeln ('Количество положительных чисел ',count);
end.
Не нашли ответ?
Похожие вопросы