Мне ооочень срочно нужно!!! пожалуйста помогите!!!!!!!!помогите решить 2 задачи по Ивт в Паскале: 1)составить программу вычисления в массиве A(N) произведения нечетных элементов 2)Составьте программу вычисления в массиве B(N) м...
Мне ооочень срочно нужно!!! пожалуйста помогите!!!!!!!!помогите решить 2 задачи по Ивт в Паскале: 1)составить программу вычисления в массиве A(N) произведения нечетных элементов 2)Составьте программу вычисления в массиве B(N) максимального среди отрицательных элементов и его номера. заранее огромное спасибо! очень нужно!
Ответ(ы) на вопрос:
var a: array [0..10] of integer;
i, m: integer;
begin
m := 1;
for i := 0 to 10 do
begin
a[i] := random(50) - 25;
writeln('[', i, '] => ', a[i]);
end;
for i := 0 to 10 do
if (a[i] mod 2 = 1) then m := m * a[i];
writeln(m);
end.
2)
var a: array [0..10] of integer;
i, m: integer;
begin
for i := 0 to 10 do
begin
a[i] := random(50) - 25;
writeln('[', i, '] => ', a[i]);
end;
for i := 0 to 10 do
if ((a[i] > a[m]) and (a[i] < 0)) then
m := i;
writeln('[', m, '] => ', a[m]);
end.
Можно и меньше циклов, это я для наглядности, чтобы всё не смешивалось =)
Не нашли ответ?
Похожие вопросы