МНОГО БАЛЛОВ!!Напишите программу на Паскале пожалуйста.Заполните одномерный массив с помощью датчика случайных чисел таким образом,чтобы все его элементы были различны(не используйте пожалуйста логарифмы и тд максимально просто...
МНОГО БАЛЛОВ!!Напишите программу на Паскале пожалуйста.Заполните одномерный массив с помощью датчика случайных чисел таким образом,чтобы все его элементы были различны(не используйте пожалуйста логарифмы и тд максимально простое оформление)
Ответ(ы) на вопрос:
Гость
Можно так (элементы будут всегда упорядочены по возрастанию):
const n=10;
var a:array[1..n] of integer;
i:integer;
begin
Randomize;
for i:=1 to n do
begin
a[i]:=i*50+random(50);
write(a[i],' ');
end;
writeln;
end.
Пример:
67 147 173 227 294 318 356 426 497 542
Не нашли ответ?
Похожие вопросы