На ленте машины Поста расположен массив из 2n ячеек. Составить программу, по которой машина Поста раздвинет на расстояние в одну ячейку две половины данного массива.
На ленте машины Поста расположен массив из 2n ячеек. Составить программу, по которой машина Поста раздвинет на расстояние в одну ячейку две половины данного массива.
Ответ(ы) на вопрос:
const
N = 5;
var
i: integer;
a: array[1..N * 2 + 1] of integer;
begin
writeln('Исходный массив: ');
for i := 1 to 2 * N do
begin
a[i] := Random(99) + 1;
write(a[i] : 5);
end;
for i := 2 * N + 1 downto N + 1 do
a[i] := a[i - 1];
a[N + 1] := 0;
writeln();
writeln('Полученный массив: ');
for i := 1 to 2 * N + 1 do
write(a[i] : 5);
end.
Не нашли ответ?
Похожие вопросы