На паскале У второклассников очень популярна следующая задача: 101=1 8181515=4 1111112=0 8888888=14 1010101=3 7000007=? Преподавателю программирования в некоем Центре для одаренных детей так понравилась эта задачка, что он реши...

На паскале У второклассников очень популярна следующая задача: 101=1 8181515=4 1111112=0 8888888=14 1010101=3 7000007=? Преподавателю программирования в некоем Центре для одаренных детей так понравилась эта задачка, что он решил именно ее использовать для проверки знаний математики 2-го класса у своих учеников. Пусть первое число x, а соответствующее ему n Входные данные Единственное неотрицательное число x, не превышающее 101001. Выходные данные Выведите n.
Гость
Ответ(ы) на вопрос:
Гость
var   x: string;   n, i: integer;   begin   readln(x);   for i := 1 to length(x) do     case x[i] of     '0', '4', '6', '9': inc(n);     '8': inc(n, 2);     end;   writeln(n); end.
Гость
{тоже как вариант} const   v: array [0..9] of integer = (1,0,0,0,1,0,1,0,2,1); var   x,n: integer; begin   read(x);   n := 0;   repeat     n := n + v[x mod 10];     x := x div 10;   until x = 0;   write(n) end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы