На вход программе подаются два целых числа: 0 меньше n меньше = 12, 0 меньше = m меньше 60, указывающие момент времени “n часов m минут”. Определите наименьшее число полных минут, которое должно пройти до того момента, ко...

На вход программе подаются два целых числа: 0 < n <= 12, 0 <= m < 60, указывающие момент времени “n часов m минут”. Определите наименьшее число полных минут, которое должно пройти до того момента, когда часовая и минутная стрелки на циферблате совпадут, не обязательно на каком-то делении. Вещественную арифметику не использовать. ABC Pascal. Пришлите скрин или полную запись программы пожалуйста
Гость
Ответ(ы) на вопрос:
Гость
var h,m,c:integer; begin write('введите часы => '); readln(h); write('введите минуты => '); readln(m); if (h=12) then h:=0; if (m < h*5) then c:=h*5-m;  if (m > h*5) then c:=(60-m)+5; writeln('стрелки совпадут через ',c,' минут'); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы