На языке Паскаль составить программу, которая в диапазоне 1...300 найдёт все тройки натуральных а,в,с, подчиняющихся равенству a^2+в^2=с^2
На языке Паскаль составить программу, которая в диапазоне 1...300 найдёт все тройки натуральных а,в,с, подчиняющихся равенству a^2+в^2=с^2
Ответ(ы) на вопрос:
// PascalABC.NET 3.2, сборка 1344 от 22.11.2016
// Внимание! В других версиях работа не гарантируется!
begin
for var a:=1 to 300 do
for var b:=1 to 300 do
for var c:=1 to 300 do
if a*a+b*b=c*c Then Write(a,',',b,',',c,' ');
end.
Не нашли ответ?
Похожие вопросы