На языке С++1)Написать программу, которая находит сумму чисел S = 1 + 2 + 3 + … до тех пор, пока S не превысит введенное натуральное число n.2)Найти предпоследнее составное число в диапазоне от 1 до n.Нарисовать блок схему ко 2...
На языке С++
1)Написать программу, которая находит сумму чисел S = 1 +
2 + 3 + … до тех пор, пока S не
превысит введенное натуральное число n.
2)Найти предпоследнее составное
число в диапазоне от 1 до n.
Нарисовать блок схему ко 2 задаче
Оч прошу помогите
Ответ(ы) на вопрос:
1.
#include
using namespace std;
void main(){
int n, s = 0;
cin >> n;
for (int i = 0; i <= n; ++i)
s += i;
cout << "sum = " << s << endl;
}
2.
#include
using namespace std;
void main(){
int n, i, j = 1;
bool b = false;
cin >> n;
i = n;
while (!b && --i > 1) {
while (++j < i)
if (i % j == 0) {
b = true;
break;
}
j = 1;
}
b ? cout << i << "\n\n" : cout << "not\n\n";
}
Не нашли ответ?
Похожие вопросы