надо срочно Составить программу, которая для любого натурального числа печатает количество цифр в записи этого числа.расписать все четко

 надо срочно  Составить программу, которая для любого натурального числа печатает количество цифр в записи этого числа. расписать все четко
Гость
Ответ(ы) на вопрос:
Гость
Строками: var s:string; begin WriteLn('vvedi chislo:'); ReadLn(s); WriteLn('chislo cifr=',length(s)); ReadLn; end; Не строками: var N,k:longint; begin write('N=');readln(N); k:=0; while N>0 do begin N:=N div 10; k:=k+1; end; write('k=',k); readln end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы