Написать программу для паскаль.С клавиатуры вводятся целые числа.Признаком конца ввода является 0.Изменить знак отрицательных чисел на противоположный.Результаты вывести на экран.
Написать программу для паскаль.С клавиатуры вводятся целые числа.Признаком конца ввода является 0.Изменить знак отрицательных чисел на противоположный.Результаты вывести на экран.
Ответ(ы) на вопрос:
Предложу решение, основанное на том, что понял из текста)
var a: integer;
begin
writeln('Вводите числа');
a:=1;
while a<>0 do begin
readln(a);
if a<0 then writeln('Противоположное число ',abs(a));
end;
readln
end.
Можно их в массив записывать, если нужно вывести красиво.
var n: integer;
s: string;
begin
writeln('Вводите числа');
repeat
readln(n);
s:= s + IntToStr(abs(n)) + ' '
until n = 0;
writeln(s);
end.
Не нашли ответ?
Похожие вопросы