Написать программу для решения следующей задачи: вычислить сумму и количество положительных элементов последовательности.
Написать программу для решения следующей задачи: вычислить сумму и количество положительных элементов последовательности.
Ответ(ы) на вопрос:
var
sum, count, t : integer;
begin
sum := 0; count := 0;
while not eoln do
begin
read (t);
if t > 0 then
begin
sum := sum + t;
count := count + 1;
end;
writeln (sum, ' ', count);
end.
если количество элементов указано
var
sum, count, t, n, i : integer;
begin
sum := 0; count := 0;
read (n);
for i := 1 to n do
begin
read (t);
if t > 0 then
begin
sum := sum + t;
count := count + 1;
end;
writeln (sum, ' ', count);
end.
Не нашли ответ?
Похожие вопросы