Написать программу которая в последовательности целых чисел определять значение

Написать программу которая в последовательности целых чисел определять значениенаименьшего числа из всех чисел.Программа получает на вход целые положительные, числа количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода не входит в числовую последовательность). Количество целых чисел не превышает 1000. Все числа не превосходят 30000 . Программа должна вывести: наименьшее число из всех чисел.
Гость
Ответ(ы) на вопрос:
Гость
На C++: #include <iostream> using namespace std; int main() { int count=1, min=30001, val; do { cin >>val; if(val>30000) val-=30000; if((val<min) && (val>0)) min=val; if(count<1000) ++count; } while(val>0); cout <<"Минимальный элемент: " <<min; return 0; }
Не нашли ответ?
Ответить на вопрос
Похожие вопросы