Написать программу которая бы по введеному номеру единицы измерения (-дециметр метр километр,миллиметр)выдавала бы соответствующие значения отрезка в метрах
Написать программу которая бы по введеному номеру единицы измерения (-дециметр метр километр,миллиметр)выдавала бы соответствующие значения отрезка в метрах
Ответ(ы) на вопрос:
var a:longint;
b:string;
begin
writeln('Введите длину');
readln(a);
writeln('Введите единицы измерения (метры/дециметры и т.д.)');
readln(b);
if b='метры' then writeln(a, ' метров')
else if b='дециметры' then writeln(a/10, ' метров')
else if b='километры' then writeln(a*1000, ' метров')
else if b='миллиметры' then writeln(a/1000, ' метров');
end.
Не нашли ответ?
Похожие вопросы