Написать программу  которая даст таблицу Q5*5. Каждый эелемент таблицы случайное число из отрезка [-30,+30]. Вычислить сумму все отрицательных и сумму положительных элементов.

Написать программу  которая даст таблицу Q5*5. Каждый эелемент таблицы случайное число из отрезка [-30,+30]. Вычислить сумму все отрицательных и сумму положительных элементов.
Гость
Ответ(ы) на вопрос:
Гость
var a,b,i,j,p,o: integer; z:real; m:array[0..31,0..31] of integer; begin randomize; for i:=1 to 5 do for j:=1 to 5 do begin z:=random; b:=random(31); if z<0.5 then m[i,j]:=b; if z>0.5 then m[i,j]:=-b; end; for i:=1 to 5 do for j:=1 to 5 do begin if m[i,j]>0 then p:=p+m[i,j]; if m[i,j]<0 then o:=o+m[i,j]; end; write(p,' ',o); end.   мда. подумать над задачкой пришлось немного) но вот результат)
Не нашли ответ?
Ответить на вопрос
Похожие вопросы