Написать программу, которая находит решения уравнения ax^3+bx=0 для любых заданных значений a и b. Пожалуйста, на паскале
Написать программу, которая находит решения уравнения ax^3+bx=0 для любых заданных значений a и b.
Пожалуйста, на паскале
Ответ(ы) на вопрос:
Гость
var a,b:integer;
x,c:real;
begin
read(a,b);
if ((-b)/a)>=0 then begin
x:=sqrt((-b)/a);
c:=-x;
writeln('x=',0);
writeln('x=',x);
writeln('x=',c);
end
else
writeln('x=',0);
end.
Не нашли ответ?
Похожие вопросы