Написать программу которая находит сумму и произведение чисел от 5 до 50 с шагом 5

Написать программу которая находит сумму и произведение чисел от 5 до 50 с шагом 5
Гость
Ответ(ы) на вопрос:
Гость
var sum,pro,i:integer; begin     i:=5;     sum:=0;     pro:=1;     while i<=50 do begin         sum:=sum+i;         pro:=pro*5;         i:=i+5;    end;    writeln('Сумма = ',sum,', Произведение = ',pro);  end.
Гость
Var s,p : BigInteger;   i : Integer; Begin   p:=1; s:=0;   For i:=1 to 10 do   Begin     s:=s+i*5;    p:=p*i*5;   end;   Writeln('Сумма: ',s);   Writeln('Произведение: ',p); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы