Написать программу которая подсчитывает произведение целых чисел введеных с клавиатуры. Произведение подсчитывается до тех пор пока вводятся числа в интервале -10 до +10
Написать программу которая подсчитывает произведение целых чисел введеных с клавиатуры. Произведение подсчитывается до тех пор пока вводятся числа в интервале -10 до +10
Ответ(ы) на вопрос:
var a,p:integer;
begin
p:=1;
repeat
readln(a);
if (a>=-10) and (a<=10) then
p:=p*a;
until (a>10) or (a<-10);
write(p)
end.
Не нашли ответ?
Похожие вопросы