Написать программу, которая просит ввести 10 целых чисел и считает сколько из них положительный, отрицательно и нулей
Написать программу, которая просит ввести 10 целых чисел и считает сколько из них положительный, отрицательно и нулей
Ответ(ы) на вопрос:
Гость
var a,n1,n2,n3,i:integer;
begin
for i:=1 to 10 do begin
write('Введите ',i, ' число ');
readln(a);
if a = 0 then n1:=n1+1 else
if a<0 then n2:=n2+1 else n3:=n3+1;
end;
writeln('Равных 0 : ',n1);
writeln('Меньше 0 : ',n2);
writeln('Больше 0 : ',n3);
end.
Не нашли ответ?
Похожие вопросы