Написать программу, которая решает уравнение ax+b = 0 (Паскаль)использовать эти ур. в качестве решения: 2x+4=0; 2x+0=0; 0x+2=0; 0x+0=0
Написать программу, которая решает уравнение ax+b = 0 (Паскаль)
использовать эти ур. в качестве решения: 2x+4=0; 2x+0=0; 0x+2=0; 0x+0=0
Ответ(ы) на вопрос:
var a,b,x:real;
begin
write('введите A');
read(A);
write('введите B');
read(B);
if (b=0) and (a<>0) then write('x - любое число');
if (a<>0) and (b<>0) then begin
x:=b/(-a);
write('x = ',x);
end;
if (a=0) and (b<>0) then write ('нет корней');
if (a=0) and (b=0) then write ('x - любое число');
end.
Не нашли ответ?
Похожие вопросы