Написать программу которая с клавиатуры вводит 5 целых чисел и вычисляет среднее арифметическое нечетных среди них.На ABC паскале пожалуйста
Написать программу которая с клавиатуры вводит 5 целых чисел и вычисляет среднее арифметическое нечетных среди них.На ABC паскале пожалуйста
Ответ(ы) на вопрос:
Гость
Var
A,S,i,n:integer;
Begin
n:=0;
S:=0;
For i:= 1 to 5 do
Begin
Read(A);
if A mod 2 <> 0 then
Begin
S:=S+A;
n:=n+1;
WriteLn(A);
End;
End;
Write(S/n);
End.
Не нашли ответ?
Похожие вопросы