Написать программу, которая в зависимости от введенного количества минут (M меньше = 60) будет подставлять слово минута в нужном падеже Например, 25 минут31 минута53 минуты(используя оператор CASE и операции DIV и MOD)

Написать программу, которая в зависимости от введенного количества минут (M <= 60) будет подставлять слово минута в нужном падеже  Например, 25 минут 31 минута 53 минуты (используя оператор CASE и операции DIV и MOD)
Гость
Ответ(ы) на вопрос:
Гость
var   M:byte; begin   write('M = '); readln(M);   case M div 10 of     1: writeln(M, ' минут');     else       case M mod 10 of         0, 5..9: writeln(M, ' минут');         1: writeln(M, ' минута');         2..4: writeln(M, ' минуты');       end;   end; end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы