Написать программу, которая вводит целые числа и складывает их, пока не будет введено число 0. вывести сумму чисел , введённых до 0.
Написать программу, которая вводит целые числа и складывает их, пока не будет введено число 0. вывести сумму чисел , введённых до 0.
Ответ(ы) на вопрос:
var
sum, num: integer;
begin
repeat
readln(num);
if (num = 0) then
break;
write(sum, ' + ', num, ' = ');
sum := sum + num;
writeln(sum);
until (false);
end.
Не нашли ответ?
Похожие вопросы