Написать программу, которая вычисляет наибольший общий делитель двух целых чисел Паскаль

Написать программу, которая вычисляет наибольший общий делитель двух целых чисел Паскаль
Гость
Ответ(ы) на вопрос:
Гость
var  a, b: integer; begin Writeln('Введите два числа'); Readln(a, b);  repeat  if a > b then a := a Mod b    else b := b Mod a;  until (a = 0) Or (b = 0);  writeln('НОД = ', a + b);  end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы