Написать программу, которая заполняет одномерный массив случайными числами (-100 до 100) и выводит на экран произведение нечетных чисел
Написать программу, которая заполняет одномерный массив случайными числами (-100 до 100) и выводит на экран произведение нечетных чисел
Ответ(ы) на вопрос:
Гость
#include
#include
using namespace std;
int main() {
int i, prod = 1;
// [5;100]
const int SIZE = rand() % 96 + 5;
int array[SIZE+1];
for(i = 0; i <= SIZE+1; i++) {
array[i] = (rand() % 201) - 100;
if (array[i] < 0) {
prod *= array[i];
}
}
cout << "произведение отрицательных чисел: " << product;
return 0;
}
Не нашли ответ?
Похожие вопросы