Написать программу на паскале через циклы while и repeat. Вычислить сумму бесконечног?
Написать программу на паскале через циклы while и repeat.
Вычислить сумму бесконечног?? сходящегося ряда с точностью eps=0.5*10^-6
Ответ(ы) на вопрос:
Указанное значение (1,175201) получится, если суммирование выполнять с k=0. В задании же начальное k=1.
1)
const eps=0.5e-6;
var a,s:real; k:integer;
begin
a:=1/(2*3); s:=a; k:=1;
while abs(a)>eps do begin
a:=a/(2*k+2)/(2*k+3);
s:=s+a;
k:=k+1;
end;
writeln('s = ',s:8:6);
end.
Результат:
s = 0.175201
2)
const eps=0.5e-6;
var a,s:real; k:integer;
begin
a:=1/(2*3); s:=a; k:=1;
repeat
a:=a/(2*k+2)/(2*k+3);
s:=s+a;
k:=k+1;
until abs(a)<=eps;
writeln('s = ',s:8:6);
end.
Результат:
s = 0.175201
Если изменить строку задания начальных значений:
a:=1; s:=a; k:=0;
то результат будет s = 1.175201
Не нашли ответ?
Похожие вопросы