Написать программу на Паскале для решения следующей задачи: Дан массив из 20 элементов. Необходимо посчитать количество пар элементов, в которых есть хотя бы 1 нечетный элемент. Под парой элементов считать 2 рядом стоящих элеме...
Написать программу на Паскале для решения следующей задачи: Дан массив из 20 элементов. Необходимо посчитать количество пар элементов, в которых есть хотя бы 1 нечетный элемент. Под парой элементов считать 2 рядом стоящих элемента.
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.1, сборка 1204 от 24.03.2016
begin
var a:=ArrRandom(ReadInteger('n='),-30,30);
a.Println;
var b:=a.Pairwise.Where(i->(i.Item1.IsOdd) or
(i.Item2.IsOdd)).Count;
Writeln('Количество пар= ',b)
end.
Тестовое решение:
n= 15
-5 7 12 -11 29 11 -28 19 20 28 -6 30 26 -14 27
Количество пар= 9
Гость
const
n = 20;
var
a: array[1..n] of integer;
m, i: integer;
begin
for i := 1 to n do
begin
a[i] := random(21) - 10;
write(a[i]:4);
end;
writeln;
for i := 1 to n - 1 do
if (a[i] mod 2 <> 0) or (a[i + 1] mod 2 <> 0) then m := m + 1;
writeln('Всего пар', m);
end.
Тестовое решение:
2 -8 8 -5 7 -8 -3 -6 -9 2 -1 -3 -8 6 10 7 -4 -8 0 -5
Всего пар 13
Не нашли ответ?
Похожие вопросы