Написать программу на паскале, которая для заданных x и n вычисляет: [latex] S=1-\frac{ x^{2} }{2!} + \frac{ x^{4} }{4!} - \frac{ x^{6} }{6!} +...+(-1)^{i} \frac{ x^{2i} }{(2i)!} [/latex], где n=количество членов ряда.
Написать программу на паскале, которая для заданных x и n вычисляет:
[latex] S=1-\frac{ x^{2} }{2!} + \frac{ x^{4} }{4!} - \frac{ x^{6} }{6!} +...+(-1)^{i} \frac{ x^{2i} }{(2i)!} [/latex], где n=количество членов ряда.
Ответ(ы) на вопрос:
Гость
var
x, a, s: real;
n, i: integer;
begin
write('Введите x и n ');
readln(x, n);
a := 1;
s := a;
for i := 1 to n do
begin
a := a * (-1) * x * x / (2 * i - 1) / (2 * i);
s := s + a;
end;
writeln('S = ', s:10:3);
end.
Не нашли ответ?
Похожие вопросы