Написать программу на паскале.Даны три числа m, n, p. Определить какое из них равно d. Если ни одно не рано d, то найти max(d-m, d-n, d-p)
Написать программу на паскале.
Даны три числа m, n, p. Определить какое из них равно d. Если ни одно не рано d, то найти max(d-m, d-n, d-p)
Ответ(ы) на вопрос:
var
m, n, p, d: real;
begin
writeln('Введите d');
read(d);
writeln('Введите m,n,p');
read(m, n, p);
if (m = d) or (n = d) or (p = d) then
begin
if (m = d) then writeln('m = d');
if (n = d) then writeln('n = d');
if (p = d) then writeln('p = d');
if (m = d) and (n = d) then writeln('m,n = d');
if (m = d) and (p = d) then writeln('m,p = d');
if (p = d) and (n = d) then writeln('p,n = d');
end else
begin
writeln('Ни одно не равно d');
if ((d - m) > (d - n)) and ((d - m) > (d - p)) then writeln('(d-m) - максимальное');
if ((d - n) > (d - m)) and ((d - n) > (d - p)) then writeln('(d-n) - максимальное');
if ((d - p) > (d - m)) and ((d - p) > (d - n)) then writeln('(d-p) - максимальное');
if ((d - m) = (d - n)) and ((d - m) = (d - p)) and ((d - n) = (d - p)) then writeln('(d-m)=(d-n)=(d-p)');
end;
end.
Не нашли ответ?
Похожие вопросы