Написать программу на языке C++. Перевести с помощью рекурсивной функции conv (n, p) за- данное натуральное число n в p-ичную систему счисления (2 ≤ р ≤ 9).

Написать программу на языке C++. Перевести с помощью рекурсивной функции conv (n, p) за- данное натуральное число n в p-ичную систему счисления (2 ≤ р ≤ 9).
Гость
Ответ(ы) на вопрос:
Гость
#include using namespace std; void conv(int n, int p) { if(n/p!=0){         conv(n/p,p);     }     cout << n%p; }  int main() {     int n, p;     string m;     cout << "Введите n:", cin >> n, cout << "\n";     cout << "Введите p:", cin >> p, cout << "\n";     conv(n,p);     return 0; } Пример: Введите n: 511 Введите p: 8 777
Не нашли ответ?
Ответить на вопрос
Похожие вопросы