Написать программу на языке C++ Вам даётся 3 числа. Требуется установить, возможно ли составить из них пифагоров треугольник. Входные данные 3 целых числа, по модулю не превышающие 2 000 000 000. Выходные данные Если из чисел в...

Написать программу на языке C++ Вам даётся 3 числа. Требуется установить, возможно ли составить из них пифагоров треугольник. Входные данные 3 целых числа, по модулю не превышающие 2 000 000 000. Выходные данные Если из чисел возможно составить пифагоров треугольник выведите "YES", иначе "NO".
Гость
Ответ(ы) на вопрос:
Гость
#include using namespace std; int main() { int a, b, c; cout << "a, b, c: "; cin >> a >> b >> c; if ((a*a+b*b==c*c)||(a*a+c*c==b*b)||(b*b+c*c==a*a))   cout << "YES"; else cout << "NO"; return 0; } Пример: a, b, c: 1960509751 395427000 1999990249 YES
Не нашли ответ?
Ответить на вопрос
Похожие вопросы