Написать программу на языке Паскаль. 1.Дан целочисленный массив из 31 элемента, в котором записаны значения температуры воздуха в марте. Элементы массива могут принимать значения от (–20) до 20. Подсчитайте среднюю температуру ...

Написать программу на языке Паскаль. 1.Дан целочисленный массив из 31 элемента, в котором записаны значения температуры воздуха в марте. Элементы массива могут принимать значения от (–20) до 20. Подсчитайте среднюю температуру по всем дням, когда была оттепель (температура поднималась выше нуля) 2. В массиве X(m) заменить элементы с четными номерами суммой элементов с нечетными номерами. Заранее спасибо)
Гость
Ответ(ы) на вопрос:
Гость
//Задание №1 //PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016) const m = 31; var a:array[1..m] of integer; i,s,n:integer; begin   for i:=1 to m do begin     a[i]:=random(-20,20);     if a[i]>0 then begin       s:=s+a[i];n:=n+1;     end;   end;   println('Температуры за месяц :'); a.println;  writeln('Средняя в оттепель :',s/n:0:3); end. Тестовое решение: Температуры за месяц : 16 7 19 -7 -18 6 12 -18 -5 -10 8 -4 10 4 10 5 -3 14 -7 -8 2 7 4 -7 18 4 -12 -5 -9 7 -5 Средняя в оттепель :9.000 //Задание №2 //PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016) const m = 10; var a:array[1..m] of integer; i,s,n:integer; begin   for i:=1 to m do begin     a[i]:=random(-20,20);     if i mod 2<>0 then s:=s+a[i];   end;   writeln('Исходный массив :'); a.println;   for i:=1 to m do     if i mod 2=0 then a[i]:=s;   writeln('Сумма на нечетных местах  = ',s);   writeln('Изиененный массив :'); a.println; end. Тестовое решение: Исходный массив : -6 15 5 -11 18 4 17 -9 -15 -16 Сумма на нечетных местах = 19 Изиененный массив : -6 19 5 19 18 19 17 19 -15 19
Не нашли ответ?
Ответить на вопрос
Похожие вопросы