Написать программу нахождения суммы четных и нечетных элементов массива, заполненного случайным образом от -100 до 100 помогите пожалуйста!!!!!нужна программа в Pascal!!!!

Написать программу нахождения суммы четных и нечетных элементов массива, заполненного случайным образом от -100 до 100 помогите пожалуйста!!!!!нужна программа в Pascal!!!!
Гость
Ответ(ы) на вопрос:
Гость
const n=10; var a:array[1..n] of integer; c,d,i: integer; begin   randomize;   for i:=1 to n do      a[i]:=random(201)-100;   Writeln('Заданные числа, с помощью рандома: ');   for i:=1 to n do      writeln(a[i],' ');    for i:=1 to n do   if a[i] mod 2=0 then c:=c+a[i] else d:=d+a[i];   Writeln('Сумма четных элементов: ',c);   Writeln('Сумма нечетных элементов: ',d); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы