Написать программу определения суммы цифр числа и их количества, используя оператор цикла с постусловием. Программа Паскаль

Написать программу определения суммы цифр числа и их количества, используя оператор цикла с постусловием. Программа Паскаль
Гость
Ответ(ы) на вопрос:
Гость
program gt; var n,q,s,k:integer; begin read(n); s:=0; k:=0; while n>0 do begin q:=n mod 10; n:=n div 10; s:=s+q; k:=k+1; end; writeln(s,' ',k); end.
Не нашли ответ?
Ответить на вопрос
Похожие вопросы