Написать программу, Паскаль. Дано натуральное число N. Вычислить S = 1! + 2! +3! + ... + n! (n больше =1) Решить через repeat (с постусловием)
Написать программу, Паскаль. Дано натуральное число N. Вычислить S = 1! + 2! +3! + ... + n! (n>=1) Решить через repeat (с постусловием)
Ответ(ы) на вопрос:
var S,f:longint; n,a:byte;
begin
s:=0;a:=1;f:=1;
readln(n);
repeat
f:=f*a;
s:=s+f;
inc(a);
until a>n;
writeln(s);
end.
Вроде так
Не нашли ответ?
Похожие вопросы