Написать программу,при выполнении которой с клавиатуры считываются координаты т?
Написать программу,при выполнении которой с клавиатуры считываются координаты т??чки на плоскости (x,y- действительные числа) и определяется принадлежность этой точки заданной закрашенной области(включая границы)
Ответ(ы) на вопрос:
Гость
Если предполагается, что прямая, проходящая через точку Х = 1.5 параллельна оси Y, тогда может получиться такой код:
var
x, y: real;
begin
write('Введите координаты точки x,y ');
readln(x, y);
if (y <= sqr(x)) and (x <= 1.5) and (x >= 0) then
writeln('Точка принадлежит фигуре')
else
writeln('Точка не принадлежит фигуре');
end.
Тест №1
Введите координаты точки x,y 1 1
Точка принадлежит фигуре
Тест №2
Введите координаты точки x,y -1 2
Точка не принадлежит фигуре
Тест №3
Введите координаты точки x,y 0 0
Точка принадлежит фигуре
Не нашли ответ?
Похожие вопросы