Написать программу, состоящую из 30 чисел, числа понимают значения от -500 до 500, программа находит минимальное значение среди нечетных элементов массива, которые кратны 5.

Написать программу, состоящую из 30 чисел, числа понимают значения от -500 до 500, программа находит минимальное значение среди нечетных элементов массива, которые кратны 5.
Гость
Ответ(ы) на вопрос:
Гость
const   n = 30; var   x: array[1..n] of integer;   i, t, min: integer; begin   Randomize;   Writeln('Элементы массива');   min:=32767;   for i := 1 to n do   begin     t := Random(1001)-500;     x[i] := t;     Write(t:5);     if Odd(i) and (t mod 5 = 0) and (min>t) then min:=t   end;   Writeln;   Writeln('Минимальный нечетный элемент, кратный 5, равен ',min) end. Тестовое решение: Элементы массива   -64  438 -290  358 -424  234 -444  -17  171  -57 -373 -279  242 -403 -262   34 -488  365  341 -468  163 -276  193 -140  126 -466 -236  -34  350 -369 Минимальный нечетный элемент, кратный 5, равен -290
Не нашли ответ?
Ответить на вопрос
Похожие вопросы