Написать программу в Паскаль абс по теме функции. задача: найти сумму цифр трех чисел.

Написать программу в Паскаль абс по теме функции. задача: найти сумму цифр трех чисел.
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016 function SoD(n:int64):integer; begin   Result:=0;   while n>0 do begin     Result+=n mod 10;     n:=n div 10     end end;      begin   var a:=ReadArrInteger('Введите три натуральных числа:',3);   Write('Суммы цифр чисел: '); a.Select(x->SoD(x)).Println;   Writeln('Общая сумма цифр всех чисел: ',a.Select(x->SoD(x)).Sum) end. Тестовое решение: Введите три натуральных числа: 56325 23131 784545223 Суммы цифр чисел: 21 10 40 Общая сумма цифр всех чисел: 71
Не нашли ответ?
Ответить на вопрос
Похожие вопросы