Написать программу в паскаль Ввести текст состоящий из слов , разделённых между собой запятыми. Сколько раз в тексте встречается слова "Мама" В найденных словах изменить букву "М" на букву "П"

Написать программу в паскаль Ввести текст состоящий из слов , разделённых между собой запятыми. Сколько раз в тексте встречается слова "Мама" В найденных словах изменить букву "М" на букву "П"
Гость
Ответ(ы) на вопрос:
Гость
// PascalABC.NET 3.2, сборка 1363 от 17.12.2016 // Внимание! Если программа не работает, обновите версию! begin   var s:=ReadlnString('>');   var a:=s.ToWords(',');   Writeln('Количество слов "Мама": ',a.Where(w->w='Мама').Count);   s:=(s+',').Replace('Мама,','Пама,'); Delete(s,s.Length,1);   s.Println end. Пример > Мама,мама,что,я,буду,делать,Мама,мама,как,я,буду,жить Количество слов "Мама": 2 Пама,мама,что,я,буду,делать,Пама,мама,как,я,буду,жить
Не нашли ответ?
Ответить на вопрос
Похожие вопросы