Написать программу в паскале. Дано натуральное число Х.Найти сумму квадратов чётных цифр в числе.

Написать программу в паскале. Дано натуральное число Х.Найти сумму квадратов чётных цифр в числе.
Гость
Ответ(ы) на вопрос:
Гость
var   x,d,s:longint; begin   Writeln('Введите натуральное число: '); Read(x);   s:=0;   while x>0 do begin     d:=x mod 10;     if d mod 2=0 then s:=s+d*d;     x:=x div 10     end;   Writeln('Сумма квадратов четных цифр равна ',s) end. Пример Введите натуральное число: 14702 Сумма квадратов четных цифр равна 20
Не нашли ответ?
Ответить на вопрос
Похожие вопросы