Написать программу в паскале: Даны целое n больше 0 и последовательность из n вещественных чисел, среди которых есть хотя бы одно отрицательное число. Найти величину наибольшего среди отрицательных чисел этой последовательности.
Написать программу в паскале: Даны целое n>0 и последовательность из n вещественных чисел, среди которых есть хотя бы одно отрицательное число. Найти величину наибольшего среди отрицательных чисел этой последовательности.
Ответ(ы) на вопрос:
var
x,max:real;
n,i:integer;
begin
write('Введите число n: ');
readln(n);
for i:=1 to n do
begin
write('Введите число ',i,': ');
readln(x);
if x<0 then
begin
if max=0 then max:=x; // если это первое отр.число
if x>max then max:=x
end
end;
writeln('Наибольшее среди отрицательных: ',max)
end.
Не нашли ответ?
Похожие вопросы