Написать программу в паскале которая будет вводить целые числа до 0, подсчитать среднее арифметическое этих чисел
Написать программу в паскале которая будет вводить целые числа до 0, подсчитать среднее арифметическое этих чисел
Ответ(ы) на вопрос:
var a,n,sum: integer;
begin
sum:=0;
n:=0;
readln(a);
while a<>0 do
begin
sum:=sum+a;
n:=n+1;
end;
writeln(sum/n);
end.
Не нашли ответ?
Похожие вопросы